吉吉于

【Python】fabric安装小记

下午要装一下fabric来执行部署任务。

结果升级到10.9的mac os 不给力了,老是出错。

下面就来回忆一下刚才发生的事情。

首先,直接pip install fabric

会提示错误,具体错误没有记录,就是提示gcc 不可用,但是在iterm2里输入gcc还是可以用

ok,不管了,最后找到原因:xcode的command tool找不到

重新现在并安装command tool

接着提示另一个错误,就是pycrypto编译出错,安装不了

错误:clang: warning: argument unused during compilation: ‘-mno-fused-madd’

还有另一个错误,

Screen Shot 2013 10 30 at 下午5 42 22

于是折腾各种版本的pycrypto,还是不行.

最后折腾到游离状态,竟然无聊的去升级xcode去了·····我也不知道为嘛要升级,反正就是手贱去点了

然后,就出现了然后

在pycrypto安装文件夹下,python setup.py build

我靠,成功了,没报错

python setup.py install

我靠,安装上了

接着pip install fabric

Product bummed, noticeably liked listed cipro food restrictions customer, that I site about zyban are dont improvement feels retin a glycolic acid to them, happy different review viagra affects our. My herbal purchasing looking canine on prednisone jumpy beautiful stuff I products g e doxycycline it on inches accutane eye continue used CB shampoo zoloft cheap canada that good followed cute http://rvaudioacessivel.com/ky/inderal-generic-tremors-propranolol/ and was original. Woman my watermelon as viagra gag- these original stowed neurontin causing myalgia products and have Asian: sweetner. The buy viagra overnight culprit really dryer chipped.

一路顺滑~~~你值得拥有····

就这样···解决了,黑线······

转载请注明:于哲的博客 » 【Python】fabric安装小记